Autor Wątek: Problem przy zapisie w Edytorze  (Przeczytany 762 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Matias00

  • Tester
  • Supporter
  • *
  • Wiadomości: 11
  • Siła reputacji: 32
  • Matias00 dyżurny ruchuMatias00 dyżurny ruchuMatias00 dyżurny ruchuMatias00 dyżurny ruchuMatias00 dyżurny ruchuMatias00 dyżurny ruchu
  • Distance Travelled: 1328km
  • Trains Routed: 332
Problem przy zapisie w Edytorze
« dnia: 04 Maj 2017, 15:36:56 »
Witam mam problem przy zapisie scenerii w edytorze. Mianowice nie pojawia się autosave i po kliknięciu na zapisz lub zapisz jako generuje się pusty plik station o treści. nie ukrywam, że zależy mi na pracy którą wykonałem od ostatniego zapisu 2,5h....
scv007;1;5;

shv001
Mapy na warsztacie:    Żyrardów 45%           Radziwiłłów Mazowiecki 0%           Grodzisk Mazowiecki 0%
Odcinek linii 001 gotowy w 15%

Offline Pixel

  • Supporter
  • *
  • Wiadomości: 9
  • Siła reputacji: 3
  • Pixel pracownik torowy
  • Distance Travelled: 1642km
  • Trains Routed: 8
Odp: Problem przy zapisie w Edytorze
« Odpowiedź #1 dnia: 05 Maj 2017, 03:32:26 »
Dołączę się do tematu, miałem taki przypadek raz na scenerii, której rozmiar pliku station.sc był w okolicach 1.1Mb ~ 1.2Mb.
Objaw który zauważyłem u siebie, to początkowo bardzo długo wyświetlana informacja o zapisie scenerii. Taki objaw był podczas kilkunastu zapisów w ciągu kilku godzin pracy (ciągłej bez restartu) w edytorze. Następnie podczas zapisu edytor załapał zwiechę i efekt taki jak u Matiasa, Niestety logi z tej akcji przepadły, więc jeśli błąd nie jest znany pozostaje gdybanie i wróżenie z fusów  :-\

Offline kam55

  • Global Moderator
  • Pioneer
  • *
  • Supporter
  • *
  • Wiadomości: 298
  • Siła reputacji: 118
  • kam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezeskam55 prezes
  • Organizator sesji
  • Distance Travelled: 3231km
  • Trains Routed: 1775
Odp: Problem przy zapisie w Edytorze
« Odpowiedź #2 dnia: 05 Maj 2017, 14:37:22 »
Bez logów ten temat sobie tu długo będzie leżał bez odpowiedzi..
--->>> TARNÓW<<<--- Sceneria Prywatna

Offline trainfun09

  • User
  • Wiadomości: 133
  • Siła reputacji: 15
  • trainfun09 zwrotniczytrainfun09 zwrotniczytrainfun09 zwrotniczy
  • Otoczeniowiec
  • Distance Travelled: 2120km
  • Trains Routed: 105
Odp: Problem przy zapisie w Edytorze
« Odpowiedź #3 dnia: 05 Maj 2017, 16:33:23 »
A próbowaliście zapisywać po krótszym czasie np.: 30min?  Nawet be log'a można stwierdzić, że edytor ma zbyt dużą ilość rzeczy do zapisania.
Przyjmuje scenerie do zrobienia otoczenia.
Obecnie: -zajęty-  (Wadowice)

Offline Pixel

  • Supporter
  • *
  • Wiadomości: 9
  • Siła reputacji: 3
  • Pixel pracownik torowy
  • Distance Travelled: 1642km
  • Trains Routed: 8
Odp: Problem przy zapisie w Edytorze
« Odpowiedź #4 dnia: 05 Maj 2017, 17:15:06 »
A próbowaliście zapisywać po krótszym czasie np.: 30min?  Nawet be log'a można stwierdzić, że edytor ma zbyt dużą ilość rzeczy do zapisania.

W moim przypadku zapisy były robione dosyć często w trakcie pracy, więc do zapisu nie było dużo danych. W międzyczasie sceneria była sprawdzana w trybie jazdy jednoosobowej.
Ładownie scenerii oraz zapis w edytorze trwały zauważalnie dłużej.

@Kam55 miejmy nadzieję, że zwrócimy uwagę innych, że taki problem występuje i jeśli sytuacja się powtórzy uda się zapisać logi.

Pozostaje tylko robić dodatkową kopię, niezależną od TD, co kilka minut, zawsze to mniejsza strata.

Offline Matz32

  • Supporter
  • *
  • Pioneer
  • *
  • Wiadomości: 211
  • Siła reputacji: 568
  • Matz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezesMatz32 prezes
  • Dziadek Mroz
    • Moj kanal kolejowy na YT
  • Distance Travelled: 4985km
  • Trains Routed: 5833
Odp: Problem przy zapisie w Edytorze
« Odpowiedź #5 dnia: 05 Maj 2017, 23:41:30 »
polecam miec okno  z folderem saved stations otwarte zeby miec podglad czy zapis przebiega prawidlowo. raz tez mi TD2 przestał przy zapisie odpowiadać  i bylo 0kb w pliku sc a  autosave tez było popsute jak na zlosc - na Szczescce mailem plik backup - eventualnie bym musial sie cofnąć do  poprzednie kopi czyli pare godzin by poszlo z dymem.Wiec polecam czeste kopie plikow poza folder z gry.
« Ostatnia zmiana: 06 Maj 2017, 10:18:09 wysłana przez Matz32 »
Buduje sie :  Mrozy/Matzowo/Sosnowo i inne takie
Jak liczy Administracja  20+15+10 rowna sie 60
Moje foty kolejowe https://www.facebook.com/Matz32

Offline guzik32

  • Supporter
  • *
  • Wiadomości: 46
  • Siła reputacji: 7
  • guzik32 pracownik torowy
  • "Nie ważne kim jesteś tylko jaki jesteś."
  • Distance Travelled: 765km
  • Trains Routed: 11
Odp: Problem przy zapisie w Edytorze
« Odpowiedź #6 dnia: 06 Maj 2017, 09:44:03 »
Takiego problemu nie miałem ani razu od kiedy działam w edytorze. Więc raczej wątpie żeby to był problem z zapisaniem dużej ilości obiektów (chyba, że na słabszym komputerze edytor bierze taką ewentualność i może coś się posypać)

na szczesice mailem plik backkup
Najlepszy sposób, zawsze działa. Sam edytując stację tworzę min 2x backup po zakończeniu wyznaczonego obszaru, żeby mieć pewność, że robota nie pójdzie w las.

Jeżeli jest log i wyłapuje błędy to musicie go tu wrzucić, bo bez tego to gdybanie będzie tak jak napisał @Kam55