Autor Wątek: Sceneria się nie odpala - Array index is out of range  (Przeczytany 780 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline MrKarakan

  • Supporter
  • *
  • Wiadomości: 14
  • Siła reputacji: 102
  • MrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezes
  • Distance Travelled: 1781km
  • Trains Routed: 652
Sceneria się nie odpala - Array index is out of range
« dnia: 01 Październik 2017, 11:03:41 »
Cześć!
Od jakiegoś czasu grzebię sobie w edytorze, coś tam ćwiczę i próbuję, aby kiedyś scenerię utworzyć.

Gdy utworzę nową mapę, pododaję trochę torów i szlaków, a następnie zapiszę i wyjdę, to przy kolejnej próbie uruchomienia scenerii w edytorze ta się nie uruchamia (podobnie jak w trybie dyżurnego). Wyświetla się błąd taki, jak w załączniku.

Co poszło nie tak? A może ja coś robię źle?
Proszę o rady i pozdrawiam ;)
« Ostatnia zmiana: 01 Październik 2017, 12:46:45 wysłana przez mentorious »

Offline MaciejakS

  • Supporter
  • *
  • Wiadomości: 211
  • Siła reputacji: 44
  • MaciejakS starszy dyżurny ruchuMaciejakS starszy dyżurny ruchuMaciejakS starszy dyżurny ruchuMaciejakS starszy dyżurny ruchuMaciejakS starszy dyżurny ruchuMaciejakS starszy dyżurny ruchuMaciejakS starszy dyżurny ruchuMaciejakS starszy dyżurny ruchu
  • Bo mnie szlag (taka ryba) jasny trafi
    • DinnerObrus
  • Distance Travelled: 4607km
  • Trains Routed: 150
Odp: Sceneria się nie odpala
« Odpowiedź #1 dnia: 01 Październik 2017, 11:23:55 »
To problem szlaków. Usuń w notatniku szlaki i spróbuj ustawić inaczej te szlaki (jeżeli to fikcyjna)
Mój fanpage kolejowy: https://www.facebook.com/MaciejakS-1525083427549225/
...::: To jak pan Jezus powiedział? Tak jak Jezus powiedział :::...

Offline mentorious

  • Artist
  • Developer
  • Supporter
  • *
  • Wiadomości: 184
  • Siła reputacji: 217
  • mentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezes
  • Distance Travelled: 2422km
  • Trains Routed: 2006
Odp: Sceneria się nie odpala
« Odpowiedź #2 dnia: 01 Październik 2017, 12:14:04 »
Podaj plik .sc w załącznik, nikt Ci nic nie wyczaruje ze screena.
« Ostatnia zmiana: 01 Październik 2017, 12:44:21 wysłana przez mentorious »

Offline MrKarakan

  • Supporter
  • *
  • Wiadomości: 14
  • Siła reputacji: 102
  • MrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezes
  • Distance Travelled: 1781km
  • Trains Routed: 652
Odp: Sceneria się nie odpala
« Odpowiedź #3 dnia: 01 Październik 2017, 12:23:39 »
Wrzucam dwa zalążki scenerii: Moczary - błąd w linijce 6.
« Ostatnia zmiana: 01 Październik 2017, 12:29:49 wysłana przez MrKarakan »

Offline mentorious

  • Artist
  • Developer
  • Supporter
  • *
  • Wiadomości: 184
  • Siła reputacji: 217
  • mentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezes
  • Distance Travelled: 2422km
  • Trains Routed: 2006
Odp: Sceneria się nie odpala
« Odpowiedź #4 dnia: 01 Październik 2017, 12:37:57 »
Wrzucam dwa zalążki scenerii: Moczary - błąd w linijce 6, Orzeszno - błąd w 34.

Moczary w linii 6 mają błąd w składni, poprawnie: x;x;x;x:,x:. Dodaj najlepiej ten krótszy szlak od nowa.

Orzeszno w liniach 34 i dalej dodałeś szlak ale bez odcinków.

Route;;ConnectionForest;2.836229;0;-511.7605;0;0;0;2;New Route;0;
EndRoute

Po ich usunięciu jest w porządku. Musisz je stworzyć na nowo albo alternatywnie dopisać w notatniku odcinki. Wyglądałoby to tak:

Route;;ConnectionForest;2.836229;0;-511.7605;0;0;0;2;New Route;0;
;70;0;1:
EndRoute

Potem odpalasz w edytorze, kasujesz odcinki i dodajesz je od nowa z niebieskiej strzałki.

W załączniku dodałem obydwie scenerie ze skasowanymi błędami odpalające się w edytorze, ale jednocześnie bez tych wadliwie wstawionych przez edytor szlaków. Powyższy kod odnoszący się do Orzeszna możesz skopiować i wkleić do pliku .sc z załącznika w następną linijkę za znacznikiem EndRoute lub samemu w edytorze dodać ten szlak od nowa.
« Ostatnia zmiana: 01 Październik 2017, 12:43:16 wysłana przez mentorious »

Offline MrKarakan

  • Supporter
  • *
  • Wiadomości: 14
  • Siła reputacji: 102
  • MrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezesMrKarakan prezes
  • Distance Travelled: 1781km
  • Trains Routed: 652
Odp: Sceneria się nie odpala
« Odpowiedź #5 dnia: 01 Październik 2017, 12:40:17 »
Pousuwałem i wszystko śmiga! Dzięki za pomoc ;)