Autor Wątek: Talk/Rozmowa: SPK na Linuksie  (Przeczytany 149 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Atmosferyczny

  • Moderator
  • Wiadomości: 180
  • Siła reputacji: 62
  • Atmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezes
SPK na Linuksie
« dnia: 28 Maja 2018, 17:43:39 »
Czy próbował ktoś uruchomić SPK na Linuxie? Mi się udało tylko częściowo, bo nie wczytuje samego pulpitu, tylko wielki czerwony X. Wyskakuje błąd .net i "A generic error occurred in GDI+." Jaka wersja .net jest potrzebna by uruchomić ten program? Jakie inne winetricksy trzeba wykorzystać? (Wersja SPK z wersji testowej Feniks)
(PS. Linux to nie moje widzimisie, po prostu Windows mi nie działa xD Długa historia, więc rady typu "Włącz windowsa" nie pomogą)

GDI+ to biblioteka graficzna, którą masz na Linuxie.
U mnie na Windows po stronie .Net odnośnie grafiki mam odwołania do:
System.Windows.Forms
System.Drawing
« Ostatnia zmiana: 09 Czerwca 2021, 12:04:29 wysłana przez Atmosferyczny »

Offline Meril

  • Global Moderator
  • Supporter
  • *
  • Wiadomości: 191
  • Siła reputacji: 309
  • Meril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezes
  • Banujcie wszystkich, Bóg pozna swoich.
Odp: SPK na Linuksie
« Odpowiedź #1 dnia: 05 Czerwca 2018, 17:13:39 »
Czy próbował ktoś uruchomić SPK na Linuxie? Mi się udało tylko częściowo, bo nie wczytuje samego pulpitu, tylko wielki czerwony X. Wyskakuje błąd .net i "A generic error occurred in GDI+." Jaka wersja .net jest potrzebna by uruchomić ten program? Jakie inne winetricksy trzeba wykorzystać? (Wersja SPK z wersji testowej Feniks)
(PS. Linux to nie moje widzimisie, po prostu Windows mi nie działa xD Długa historia, więc rady typu "Włącz windowsa" nie pomogą)
« Ostatnia zmiana: 09 Czerwca 2021, 11:51:49 wysłana przez Atmosferyczny »

Offline mentorious

  • Zasłużony
  • Supporter
  • *
  • Wiadomości: 298
  • Siła reputacji: 257
  • mentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezesmentorious prezes
Odp: SPK na Linuksie
« Odpowiedź #2 dnia: 05 Czerwca 2018, 20:10:48 »
winetricks gdiplus
Powinno pomoc.

Offline Meril

  • Global Moderator
  • Supporter
  • *
  • Wiadomości: 191
  • Siła reputacji: 309
  • Meril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezes
  • Banujcie wszystkich, Bóg pozna swoich.
Odp: SPK na Linuksie
« Odpowiedź #3 dnia: 05 Czerwca 2018, 20:44:22 »
GDI+ dał tyle że nie ma błędu z nim, ale nadal nie działa. Wywala taki błąd:
Spoiler: pokaż
"See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Parameter is not valid.
   at System.Drawing.Bitmap..ctor(Type type, String resource)
   at SPK.KostkaLicznik.PrePaint(Graphics g)
   at SPK.Pulpit.OnPaint(PaintEventArgs pe)
   at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
   at System.Windows.Forms.Control.WmPaint(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
SPK
    Assembly Version: 1.0.6645.30469
    Win32 Version: 1.0.6645.30469
    CodeBase: file:///Z:/home/rafal/td2-close_test/Tools/SPK/SPK.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

I jak się go pominie wychodzą "Parametr not valid" Na różnych pulpitach w innej linii, i nadal wielki czerwony X. .Net mam bodajże 4.0

Offline Atmosferyczny

  • Moderator
  • Wiadomości: 180
  • Siła reputacji: 62
  • Atmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezesAtmosferyczny prezes
Odp: SPK na Linuksie
« Odpowiedź #4 dnia: 05 Czerwca 2018, 22:36:49 »
GDI+ dał tyle że nie ma błędu z nim, ale nadal nie działa. Wywala taki błąd:
Spoiler: pokaż
"See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Parameter is not valid.
   at System.Drawing.Bitmap..ctor(Type type, String resource)
   at SPK.KostkaLicznik.PrePaint(Graphics g)
   at SPK.Pulpit.OnPaint(PaintEventArgs pe)
   at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
   at System.Windows.Forms.Control.WmPaint(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
SPK
    Assembly Version: 1.0.6645.30469
    Win32 Version: 1.0.6645.30469
    CodeBase: file:///Z:/home/rafal/td2-close_test/Tools/SPK/SPK.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

I jak się go pominie wychodzą "Parametr not valid" Na różnych pulpitach w innej linii, i nadal wielki czerwony X. .Net mam bodajże 4.0

Nie wiem co Ci poradzić.
Mam ustawioną platformę docelową .NET Framework 4.5
Sam zapis błędu wskazuje, że wystąpił podczas rysowania kostki licznika. Tam pobierana jest bitmapa z zasobów osadzonych o nazwie "Licznik.bmp" i tu właśnie się wysypuje. Trudno powiedzieć o co chodzi. Takie kreowanie bitmapy dostępne jest od wersji .NET 1.0
https://msdn.microsoft.com/pl-pl/library/47591zc7(v=vs.110).aspx

Offline Meril

  • Global Moderator
  • Supporter
  • *
  • Wiadomości: 191
  • Siła reputacji: 309
  • Meril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezesMeril prezes
  • Banujcie wszystkich, Bóg pozna swoich.
Odp: SPK na Linuksie
« Odpowiedź #5 dnia: 20 Czerwca 2018, 19:08:44 »
Wracając do tematu linuxa: Próbowałem odpalić przez konsole SPK. Takie rzeczy mi wypisało:
wine SPK.exe
err:ole:CoGetContextToken apartment not initialised
wine: Call from 0x7b43c89c to unimplemented function api-ms-win-core-winrt-roparameterizediid-l1-1-0.dll.RoGetParameterizedTypeInstanceIID, aborting
// to samo powtórzone kilkadziesiąt razy
wine: Call from 0x7b43c89c to unimplemented function api-ms-win-core-winrt-roparameterizediid-l1-1-0.dll.RoGetParameterizedTypeInstanceIID, aborting
A w załączeniu screen co wyszło. Potem komunikat błędu jak wcześniej i zmiana na wielki czerwony X.
Wygląda na to że nie udało się poprawnie zainstalować dotneta4.5 i zostało na 4.0, ale teraz nie mogę jeszcze raz zainstalować 4.5 bo twierdzi że jest w konflikcie z 4.0 ::)
Może założyć wątek spk na linuxie, a nie spamować tutaj?
Szkoda że niektóre scenerie są tylko na SPK a nie mają SCS...